SQL SERVER – Error: 26014, Severity: 16. Unable to Load User Specified Certificate

Recently I was consulting a customer and they had plans to change certificate used by SQL Server. After making changes to certificate, we found that we were not able to start the SQL Server Service. Let us learn about how to fix error 26014 about unable to load User Specified Certificate.

A wax-sealed envelope lying on a doormat with the wax seal cracked cleanly in half.

Below were the errors in the SQL Server ERRORLOG. SQL SERVER – Where is ERRORLOG? Various Ways to Find ERRORLOG Location

2016-06-29 01:59:48.07 Server Error: 26014, Severity: 16, State: 1.
2016-06-29 01:59:48.07 Server Unable to load user-specified certificate [Cert Hash(sha1) “692169CAAE3FA02AB216876A6CC468B60BB4C153”]. The server will not accept a connection. You should verify that the certificate is correctly installed. See “Configuring Certificate for Use by SSL” in Books Online.
2016-06-29 01:59:48.07 Server Error: 17182, Severity: 16, State: 1.
2016-06-29 01:59:48.07 Server TDSSNIClient initialization failed with error 0x80092004, status code 0x80. Reason: Unable to initialize SSL support. Cannot find object or property.

I looked into certificate and found that 692169CAAE3FA02AB216876A6CC468B60BB4C153 was a valid thumbprint in properties of certificate. Tried various options and searched on internet.

We also verified that below key has correct thumbprint value. HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\<instance>\MSSQLServer\SuperSocketNetLib

Solution / Workaround:

Finally, we changed the service account from NT SERVICE\MSSQLSERVER to LocalSystem and we were able to start SQL server service.

Let me know if you have faced this error on your production server.

Published by Pinal Dave on SQLAuthority. More of my work at pinaldave.com.


Discover more from SQL Authority with Pinal Dave

Subscribe to get the latest posts sent to your email.

SQL Error Messages, SQL Log, SQL Server, SQL Server Encryption
Previous Post
SQL Server – Understanding Connection Timeouts and Query Timeouts
Next Post
SQL SERVER – Database going to Recovery Pending Automatically and Coming Back

Related Posts

1 Comment. Leave new

  • Hello, Is there any other work around this problem? I used this to fix the issue on my UAT environment, but I will not be able to change the service account on Production as it is a domain account. Thanks.

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

Fill out this field
Fill out this field
Please enter a valid email address.