As you might know I try hard to help the community via various channels. Comment on my blog is one of that channels. Here is a blog post which talks about error about Unauthorized Operation.
Recently, one of my community members shared a SQL Server 2016 setup log which me. He wanted to understand why he was seeing below error
Attempted to perform an unauthorized operation.
I asked complete log and below is what we saw.
Error: Local Discovery
(01) 2016-07-30 04:23:21 Slp: Running Action: RunRemoteDiscoveryAction
(01) 2016-07-30 04:23:21 Slp: Running discovery on local machine
(01) 2016-07-30 04:23:23 Slp: Discovery on local machine is complete
Error: Node MyNode02
(01) 2016-07-30 04:23:23 Slp: Running discovery on remote machine: MYNODE02
(01) 2016-07-30 04:23:24 Slp: Discovery on MYNODE02 failed due to exception
Error: Node MyNode03
(01) 2016-07-30 04:23:24 Slp: Running discovery on remote machine: MYNODE03
(01) 2016-07-30 04:23:28 Slp: Discovery on MYNODE03 is complete
I have highlighted section of log. First one is Local Discovery which worked. Second one was for node MyNode02 which failed with error and for third remote node MyNode03 it worked.
I asked him to check below.
- Start > Run > RegEdit
- File > Connect Network Registry.

- Provide remote machine name and connect.
He informed me that he was getting below error:

Solution: As explained in the error message, after starting “remote registry” service, the issue was resolved.
Have you ever seen some other setup error?
Published by Pinal Dave on SQLAuthority. More of my work at pinaldave.com.




