SQL SERVER – Unable to Bring Resource Online – Error – Could Not Find Any IP Address that this SQL Server Instance Depends Upon

When it rains, it pours. In the last few days last few contacts from my customers were for cluster related issues. Once again, SQL Server resource was not coming online in failover cluster manager. I asked them to check if ERRORLOG is being generated and if yes, share the content. SQL SERVER – Where is ERRORLOG? Various Ways to Find ERRORLOG Location. Let us learn how to fix Unable to Bring Resource Online.

Here are the messaged reported in ERRORLOG.

2016-10-27 08:27:09.71 spid10s Error: 26054, Severity: 16, State: 1.
2016-10-27 08:27:09.71 spid10s Could not find any IP address that this SQL Server instance depends upon. Make sure that the cluster service is running, that the dependency relationship between SQL Server and Network Name resources is correct, and that the IP addresses on which this SQL Server instance depends are available. Error code: 0x103.
2016-10-27 06:28:11.72 spid10s Error: 17182, Severity: 16, State: 1.
2016-10-27 06:28:11.72 spid10s TDSSNIClient initialization failed with error 0x103, status code 0xa. Reason: Unable to initialize the TCP/IP listener. No more data is available.
2016-10-27 06:28:11.72 spid10s Error: 17182, Severity: 16, State: 1.
2016-10-27 06:28:11.72 spid10s TDSSNIClient initialization failed with error 0x103, status code 0x1. Reason: Initialization failed with an infrastructure error. Check for previous errors. No more data is available.
2016-10-27 06:28:11.73 spid10s Error: 17826, Severity: 18, State: 3.
2016-10-27 06:28:11.73 spid10s Could not start the network library because of an internal error in the network library. To determine the cause, review the errors immediately preceding this one in the error log.
2016-10-27 06:28:11.74 spid10s Error: 17120, Severity: 16, State: 1.
2016-10-27 06:28:11.74 spid10s SQL Server could not spawn FRunCommunicationsManager thread. Check the SQL Server error log and the Windows event logs for information about possible related problems.

I asked them the change which they made in this cluster and the informed that they changed virtual server name of SQL Server.

SOLUTION/WORKAROUND

Since resources were recreated and dependencies were not set properly. Here is the dependency tree.

  • SQL Server > Depends on All Disks and Network Name.
  • Network Name > Depends on IP Address.
  • IP Address > Depends on None.
  • Disks > Depends on None. If there are mount points, then they would have dependency on disk.
  • SQL Server Agent > Depends on SQL Server.

The easiest way to see dependency is by using inbuilt tools of the Cluster Manager as shown below.

Failover Cluster Manager role menu with More Actions, Show Dependency Report highlighted

Once dependencies were corrected, SQL Server was able to come online.

Have you faced a similar error with some other solution?

Published by Pinal Dave on SQLAuthority. More of my work at pinaldave.com.

Computer Network, SQL Error Messages, SQL Server, Starting SQL
Previous Post
SQL SERVER – FIX: Incorrect Syntax Near the Keyword ‘PROCEDURE’
Next Post
In-Place Upgrade or Side by Side: Choosing Properly

Related Posts

2 Comments. Leave new

  • These all are basic things and every thing is in place. But SQl dint start because of login account change.

    Reply
  • Not only check dependency. also make sure the sql service account for each instance has full control of the cluster name if the cluster is rebuilt

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

Fill out this field
Fill out this field
Please enter a valid email address.