SQL SERVER – Service Pack Error – Index (Zero Based) Must be Greater Than or Equal to Zero and Less Than the Size of the Argument List

Error dialog for SQL Server 2014.Recently I came across an issue where I was not able to fix directly. My client reported below error in Skype, which is related to a service pack. 
Overall summary:
Final result: The patch installer has failed to update the shared features. To determine the reason for failure, review the log files.
Exit code (Decimal): -2068774911
Exit facility code: 1201
Exit error code: 1
Exit message: Index (zero based) must be greater than or equal to zero and less than the size of the argument list.

I asked them to check below article

https://support.microsoft.com/en-us/help/2379466/fix-0x84b10001-error-code,-sql-server-2008-or-sql-server-2008-r2-setup-failure,-and-an-unhandled-exception-occur-when-you-run-sql-server-2008-or-sql-server-2008-r2-setup

But they were using SQL Server 2016 and having issues with latest patch. As per above “There are many possible scenarios that may initiate this issue. For example, a failure of a previous installation of SQL server may corrupt the registry, and this registry corruption may initiate this issue.”

I asked for Detail.txt and contains following details:

Microsoft.SqlServer.Configuration.MsiExtension.SetPatchInstallStateAction.GetInstalledPatchBySQLDiscovery
at Microsoft.SqlServer.Configuration.MsiExtension.SetPatchInstallStateAction.GetInstalledPatch
at Microsoft.SqlServer.Configuration.MsiExtension.SetPatchInstallStateAction.ExecuteAction
at Microsoft.SqlServer.Configuration.MsiExtension.ProductInstallProperty.GetInstalledPackages
at Microsoft.SqlServer.Configuration.MsiExtension.ProductInstallProperty.CollectProductData

WORKAROUND/SOLUTION

From above stack it looks like an issue with MSI/MSP missing issue. My client informed that they have already tried repair and it didn’t help. When I looked around on the internet, it sounded like they have some registry keys missing. I have suggested them to format the machine (after taking data backup) and install a fresh operating system. Later they did the same and restored the databases to the new instance.

Let me know if you have faced this error related to a service pack.

Published by Pinal Dave on SQLAuthority. More of my work at pinaldave.com.

SQL Error Messages, SQL Server, SQL Server Installation, SQL Service Pack, SQL Setup
Previous Post
SQL SERVER – FIX: The SQL Server Failed to Initialize VIA Support Library [QLVipl.dll]
Next Post
SQL SERVER – FIX: Msg 3132, Level 16 – The Media Set has 2 Media Families but Only 1 are Provided. All Members Must be Provided

Related Posts

Leave a Reply

Your email address will not be published. Required fields are marked *

Fill out this field
Fill out this field
Please enter a valid email address.