Yesterday I came across following error while enabling fill factor for my database server, when I was trying to write article SQL SERVER – 2008 – 2005 – Rebuild Every Index of All Tables of Database – Rebuild Index with FillFactor. The error was Msg 5834, and the fix turned out to be one small change.

I ran following T-SQL script and it gave me error.
sp_configure 'show advanced options', 1 GO RECONFIGURE GO sp_configure 'fill factor', 90 GO RECONFIGURE GO
In result pan following error showed up.
Msg 5834, Level 16, State 1, Line 1
The affinity mask specified conflicts with the IO affinity mask specified. Use the override option to force this configuration.
Fix/Solution/Workaround:
Add option OVERRIDE along with RECONFIGURE command.
sp_configure 'show advanced options', 1
GO
RECONFIGURE WITH OVERRIDE
GO
sp_configure 'fill factor', 90
GO
RECONFIGURE WITH OVERRIDE
GO
Published by Pinal Dave on SQLAuthority. More of my work at pinaldave.com.





2 Comments. Leave new
Nice one!
Hi Pinal,
Brilliant post as ever, the ‘WITH OVERRIDE’ option has sorted out my problem.
What does the actual error mean though?
How about a post demystifying Affinity Mask , I/O Mask and parallelism?
rgds
rich