Domain Controller – Startup Issue – Unable to Use Domain Account as Service Account When Read Only Domain Controller (RODC) is Involved

SQL Server would not start under a domain account when a Read Only Domain Controller (RODC) was involved. Here is what fixed it.